Page 1 of 1 1
Topic Options
#211506 - 2016-05-16 01:31 PM Kixtart default script
mohammed Offline
Fresh Scripter

Registered: 2016-05-16
Posts: 6
Loc: London
Hi all,

I am new to Kixtart so apologies if my question has been asked before. At my worksplace, we are currently running a version of Kixtart which is several years old. In the logon script field for users in active directory, users have Kix32.exe which points to the default script kixtart.kix and works fine. However, in a test environment I have installed the latest version of Kix (2010 4.66) and I cannot seem to get it to work without entering both kix32.exe and kixtart.kix in the logon script field. Is there a way of making Kix look for the default script in the new version? Any information will be useful.

Many thanks

Mo

Top
#211507 - 2016-05-16 03:34 PM Re: Kixtart default script [Re: mohammed]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2119
Loc: Tulsa, OK
I believe this is a known issue since around version 4.6. Someone correct me if I'm wrong. The solution is to simply put the path of the script as well, which as you've noticed, works fine.

I know it adds a level of work to change everyone's login script field in AD. But it's not as hard as you might think, since I think you can select more than one user at a time and edit the field for all at once.

See the following post where the same issue was discussed.

http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Board=1&Number=210505


Edited by ShaneEP (2016-05-19 03:06 PM)

Top
#211508 - 2016-05-16 05:46 PM Re: Kixtart default script [Re: ShaneEP]
mohammed Offline
Fresh Scripter

Registered: 2016-05-16
Posts: 6
Loc: London
I have over a thousand users to update then lol that should be fun! Thank you for clearing that up! I presume this bug will be fixed in future builds which means that the logon script field will have to be amended back to kix32.exe again for over a thousand users?
Top
#211509 - 2016-05-16 06:00 PM Re: Kixtart default script [Re: mohammed]
Glenn Barnas Administrator Online   content
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4372
Loc: New Jersey
Hi Mohammed - welcome to KORG!

This bug occurred in earlier versions of 4.6. If you are running version 4.66, the bug is NOT present, and running "kix32.exe" will automatically invoke "kixtart.kix" if it is in the same folder.

Things to check:
  • From a command prompt, run "\\[DOMAIN]\NetLogon\Kix32.exe /?"
    Verify that it reports Version 4.66. If not, you need to update the version in your NetLogon folder. (Be sure to replace "[DOMAIN]" with the NetBIOS name of your domain.)
  • From a command prompt, run "\\[DOMAIN]\NetLogon\Kix32.exe \\[DOMAIN]\NetLogon\Kixtart.kix"
    Verify that the login script runs. If not, make sure that the script in the NetLogon folder is properly called "kixtart.kix".
I'm running 4.66 here and when I run "Kix32.exe" it properly invokes "kixtart.kix" from the current directory without me specifying it.

If you DO have to specify "Kix32.exe Kixtart.kix" in the Logon Script setting of the user profile, you CAN select ALL of the user accounts and change just the Logon Script field. Be sure that everyone you select is supposed to run the same script! (I've done this in environments with 25,000 users, selecting one OU's worth of accounts at a time. It took just a couple of minutes to complete.

Glenn


Edited by Glenn Barnas (2016-05-16 08:02 PM)
Edit Reason: fixed missing tag
_________________________
Actually I am a Rocket Scientist! \:D

Top
#211510 - 2016-05-16 06:22 PM Re: Kixtart default script [Re: Glenn Barnas]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2119
Loc: Tulsa, OK
Thanks for clearing that up Glenn. I've never run scripts that way, and wasn't sure if it got fixed or not.
Top
#211513 - 2016-05-17 10:47 AM Re: Kixtart default script [Re: ShaneEP]
mohammed Offline
Fresh Scripter

Registered: 2016-05-16
Posts: 6
Loc: London
Hi Glen, thank you for your help.

Typing in the following: "\\[DOMAIN]\NetLogon\Kix32.exe /?" reports: kixtart 2010 4.66 and typing in the following command: "\\[DOMAIN]\NetLogon\Kix32.exe \\[DOMAIN]\NetLogon\Kixtart.kix" brings up the kix script however, I am still not able to get script to load automatically by just using Kix32.exe in the login field.

In the netlogon share kix is named as: KIX32 with an extension of .exe and the kix script is named as: Kixtart with an extension of .kix I believe that I have set everything up properly but still cannot get the Kix32.exe to look for the default script at startup.

Many thanks

Mo

Top
#211518 - 2016-05-19 10:30 AM Re: Kixtart default script [Re: mohammed]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4671
Loc: The Netherlands
Just to be on the safe side I made it a habit to add the script name to the logon script field in AD for each user that needs the logon script. This will also prevent any issues may the bug be reintroduced somehow in the future. It does not hurt to have in there even if the bug is fixed so there is no real need to change it back.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#211519 - 2016-05-19 11:25 AM Re: Kixtart default script [Re: mohammed]
piotrb Offline
Fresh Scripter

Registered: 2005-05-18
Posts: 11
Loc: Poland
Hello!

I test Kix version 4.66 and I have the same isue.
(Kix32 AND scripts (kixtart.kix and <username>.kix) are in Netlogon share, Kix runs from Profile\Logon Script in AD.)

"Kix32 kixtart.kix" runs ok
"Kix32" alone runs <username>.kix script
"Kix32" alone NOT run kixtart.kix script.

What can I check or maybe it is still a bug in 4.66 version?
Thanks

Top
#211520 - 2016-05-19 11:51 AM Re: Kixtart default script [Re: piotrb]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4671
Loc: The Netherlands
If kix32.exe and kixtart.kix are in the same folder then it should automaticaly start kixtart.kix. I just did a test and it works fine for me. Looks like there is something going on with some setups or the bug pops up in some specific situations. 4.66 work fine for me on Windwos 7 SP1 x64.

This small script
 Code:
Break on

? @KIX
? @SCRIPTNAME
? @SCRIPTEXE
? @DATE
? @TIME

Sleep 10


gives me

 Quote:

D:\KiXtart 4.66>kix32.exe

4.66
KIXTART.KIX
KIX32.EXE
2016/05/19
11:49:05
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#211521 - 2016-05-19 12:27 PM Re: Kixtart default script [Re: Mart]
piotrb Offline
Fresh Scripter

Registered: 2005-05-18
Posts: 11
Loc: Poland
Hello Mart!

Yes, of course, my Kix32.exe (v 4.66) run Your script from the same folder (on local drive);
and when I run Kix from share \\server\netlogon\kix32.exe it is running my kixtart.kix from this share too (via Windows GUI).
But command "kix32" in "Logon Script" field in AD is not running this script automatically.

When I switch kix exe file to old 4.22 version and try to login to client machine - script is starting fine.
For script named .kix it is OK too.

My users have BAT file to run Kix in AD Profile, but I want to remove BAT and switch to "Kix32" only command, but without success.
(My servers are on Win 2k8 R2, client Win 7 x64 SP1)

Top
#211523 - 2016-05-19 01:56 PM Re: Kixtart default script [Re: piotrb]
Glenn Barnas Administrator Online   content
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4372
Loc: New Jersey
I created a bug report in the BETA forum - see this post.

It almost seems that Kix32 is checking for:
  • @SCRIPTDIR\@USERID.kix (works)
  • @CURDIR\kixtart.kix (works when both script and exe are in the CURRENT folder, but since the NetLogon share isn't the current folder during logon, it fails at logon.)
This broke in 4.60 but was partially fixed a few releases back. Since most of us updated the login profile to read "Kix32.exe kixtart.kix" and simply tested the way Mart and I did, we assumed that it worked. My AD still has the full spec.

Clearly, this is still broken from the perspective of a logon process using Kix32.exe alone. Our script handles the user-specific script internally via a {UserID}.ini, but others who depend on this user-specific script feature are impacted by this bug.

Glenn
_________________________
Actually I am a Rocket Scientist! \:D

Top
#211524 - 2016-05-19 07:05 PM Re: Kixtart default script [Re: Glenn Barnas]
NTDOC Administrator Online   content
Administrator
*****

Registered: 2000-07-28
Posts: 11619
Loc: CA
If it was not specifically geared as a "login script" application I wouldn't consider it a bug as there is nothing in the environment to find kixtart.kix. Ruud has to be doing some behind the scenes work to look/find that file from a login share. Since it's documented to work that way I believe then okay but for the past 15+ years I've been using one of these.

kix32.exe logon.kix (long time ago when I used console for feedback)
wkix32.exe logon.kix (long time now using this method as I don't give any feeback at login anymore)

3 different networks and has worked for me at all of them this way with no issue now since the 3.x versions on up.

Top
#211525 - 2016-05-19 10:39 PM Re: Kixtart default script [Re: NTDOC]
Glenn Barnas Administrator Online   content
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4372
Loc: New Jersey
It's technically a bug because Ruud said it was, and he said that he fixed it! \:D
_________________________
Actually I am a Rocket Scientist! \:D

Top
#211839 - 2016-08-03 04:40 PM Re: Kixtart default script [Re: Glenn Barnas]
mohammed Offline
Fresh Scripter

Registered: 2016-05-16
Posts: 6
Loc: London
Thank you all for your help. I am just going to edit the logon script field in bulk for all users in Active Directory. This should resolve the issue that I'm experiencing.
Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart 
Hop to:
Shout Box

Who's Online
1 registered (Allen) and 229 anonymous users online.
Newest Members
MLewis, mtb85, caveman4961, MarkPippin, polbanget
17809 Registered Users

Generated in 0.072 seconds in which 0.027 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org