#195765 - 2009-09-04 03:30 PM
Windows 7 and Kixtart scripts?
|
cwhitmore
Starting to like KiXtart
Registered: 2001-05-23
Posts: 102
Loc: Austin, Texas, USA
|
I just joined my Windows 7 Pro RTM to our Windows 2003 domain and logged in. Looks like the drive mappings don't work. What's the new syntax for mapping drive letters in Windows 7?
|
|
Top
|
|
|
|
#195766 - 2009-09-04 04:25 PM
Re: Windows 7 and Kixtart scripts?
[Re: cwhitmore]
|
Radimus
Moderator
   
Registered: 2000-01-06
Posts: 5187
Loc: Tampa, FL
|
|
|
Top
|
|
|
|
#196468 - 2009-10-24 02:15 PM
Re: Windows 7 and Kixtart scripts?
[Re: NTDOC]
|
YoshiGP
Just in Town
Registered: 2009-10-24
Posts: 1
Loc: Germany
|
I have the same situation with a new installed Windows 7 Professional. All our WinXP and WinVista are running the login correctly. But on our new Win7 it doesn`t work.
-- snip --
MessageBox ("Willkommen bei"+chr(9)+": "+"C/S/G"+chr(10)+ chr(10)+
"Datum"+chr(9)+chr(9)+": "+@day+" "+@mdayno+" "+@month+" "+@year+chr(10)+
"Zeit"+chr(9)+chr(9)+": "+@time+chr(10)+ chr(10)+
"User ID"+chr(9)+chr(9)+": "+@userid+chr(10)+
"Privileges"+chr(9)+chr(9)+": "+@priv+chr(10)+ chr(10)+
"Prozessor"+chr(9)+chr(9)+": "+@CPU+chr(10)+ chr(10)+
"Speed"+chr(9)+chr(9)+": "+@MHZ+" MHz"+chr(10)+
"Speicher"+chr(9)+chr(9)+": "+MemorySize()+" MB"+chr(10)+ chr(10)+
"OS-Name"+chr(9)+chr(9)+": "+@PRODUCTTYPE+chr(10)+
"OS-Version"+chr(9)+": "+@dos+chr(10)+ chr(10)+
"Terminal-Session"+chr(9)+": "+$TS+chr(10)+
"Domain"+chr(9)+chr(9)+": "+@domain+chr(10)+
"Logon Server"+chr(9)+": "+@lserver+chr(9)+chr(9)+chr(10)+
"Computername"+chr(9)+": "+@wksta+chr(10)+
"Node adress"+chr(9)+": "+@address+chr(10)+chr(10)+
$greeting, "Anmelde Information", 4160, 10)
; *********************************
; * Laufwerke Client mappen Anfang
; *********************************
use * /Delete
IF @TSSESSION <> 1
if ingroup("Mapping_R_Exchange-Archive")
use R: "\\SERVER\Exchange-Archive"
endif
-- snip --
Messagebox appears. TSSESSION is not 1. It works on all the other installations of WinXP and WinVista with the same user. tried for debugging to change the servername with the IP, but it`s not working too.
If I start the script manually from Win 7 and not via ActiveDirectory-Login it works fine.
Any ideas?
Edited by Mart (2009-10-25 12:46 PM) Edit Reason: Please use code tags when posting code.
|
|
Top
|
|
|
|
#196639 - 2009-11-11 06:33 AM
Re: Windows 7 and Kixtart scripts?
[Re: Allen]
|
AlonSeal
Just in Town
Registered: 2009-11-11
Posts: 2
Loc: Maryland, USA
|
I can second that. Kix script that has worked for years, can't map drives during logon on Windows 7. It goes through the routine like it worked, but in Explorer or CMD, the drive are not there. When the script is manually ran after login, the mapped drives shows up.
Kix 4.6 and 4.61 Windows 7 x64 Pro 6.1.7600 Windows 2003 AD
My script looks like this, which works fine for XP SP3 cls ? ? color w+/n ? "Default Domain GPO Logon Script" ? sleep 5 ? color w/n use x: "\\wind-dvr\photos" ? @error ? @serror if @error = 0 ? "Drive X mapped for Photos" endif use y: /d use y: "\\wind-dvr\mp3data" ? @error ? @serror if @error = 0 ? "Drive Y mapped of MP3s" endif use list ? sleep 20
and the output looks like this:
Default Domain GPO Logon Script
0 The operation completed successfully. Drive X mapped for Photos 0 The operation completed successfully. Drive Y mapped of MP3s Current redirections :
X: --> \\wind-dvr\photos Y: --> \\wind-dvr\mp3data
This kix script is started off in my OU's GPO, by a CMD file that looks like this:
@echo off %logonserver%\netlogon\kix\kix32.exe %logonserver%\sysvol\dxb.lan\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\USER\Scripts\Logon\default.kix rem net use x: \\wind-dvr\photos rem net use y: \\wind-dvr\mp3data
(I rem-ed out the two "net use" lines. They were added once I discovered that the kix script was no longer mapping my x: and y: drive. They work. I rem-ed them out to retest the kix script.)
Edited by AlonSeal (2009-11-11 06:44 AM)
|
|
Top
|
|
|
|
#196696 - 2009-11-14 06:28 AM
Re: Windows 7 and Kixtart scripts?
[Re: Allen]
|
AlonSeal
Just in Town
Registered: 2009-11-11
Posts: 2
Loc: Maryland, USA
|
Yup, that fixed it. Thanks. Since I skipped Vista and when right to W7, I missed all the information on access token. Guess it's time to dive into learning all the in's and out's of the new platform.
Thanks for the help.
|
|
Top
|
|
|
|
#196776 - 2009-11-19 08:47 PM
Re: Windows 7 and Kixtart scripts?
[Re: AlonSeal]
|
Turkey77
Fresh Scripter
Registered: 2007-04-05
Posts: 6
Loc: Pennsylvania
|
Kudos Allen, the EnableLinkedConnections registry entry worked for me as well. Do you know what is causing this issue? Or am I going to have to apply this to all of my win7 boxes?
Running win7 with 2008/2003 mixed domain.
thanks for your help
this reg fix also allows InGroup to function as desired
Edited by Turkey77 (2009-11-19 08:50 PM) Edit Reason: forgot to mention the InGroup works for me now too
|
|
Top
|
|
|
|
Moderator: Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart
|
1 registered
(morganw)
and 925 anonymous users online.
|
|
|