I think Les has the answer. Rings a bell now. If the user shuts down and restarts then logs on using dial up it works. Only fails when dialing after logging in. I don't think I want to point them at a specific server to fix it though. Still doesn't answer why NT scripted mappings are remembered (red X) when offline but Kix mapped drives aren't. Anyway thanks for the ideas.