Hey Bryce... check this out... Run PS scripts right in Kix.

Function PSShell($FQFN, optional $PSObject, optional $output)
if $PSobject=""
if $PSObject.init(not 0)
if exist($fqfn)
if $output
$PSObject.outputmode = $output
$PSObject.outputmode = 2
$PSObject.execute('Set-ExecutionPolicy Unrestricted')
$PSObject.execute('& "' + $FQFN + '"')

A couple of things about this... first I ran into the permissions thing. I guess not allowing any PS scripts by default is a good thing, but talk about frustrating when you don't really understand why. Here is the article I found that help with this: http://technet.microsoft.com/en-us/library/ee176949.aspx

Next I ran into the problem of still not being able to run the script. The examples all said either fullpath\script or .\script or by setting an environment variable. Nothing was working. Happened to notice that it was truncating the directory and found the following link on what to do when there is a space in the path name... http://arcware.net/running-a-powershell-script-with-a-space-in-the-path/

I finally got it to work. I'm assuming the & is a escape character, but have yet to find anything concrete explaining its purpose. Anyone?