Why would "Del" be a command, but "SetFileAttr" be a function?
They both have parameters, and neither has a return value other than the success status.
To turn it the other way around, why is "GetS" a command, and "FreeFileHandle" a function? Neither has a parameter, so for consistancy either "GetS" should be a function, or "FreeFileHandle" should be a command.
AT() is another odd-ball.
I'm just responding to schneiders request for clarification.
The point is KiXtart is inconsistant and a little strange because of the way it has developed over time, and the need to preserve backwards compatibility.
We all look back at our early code and think "Well, I could have done that better."
One of the Unix authors was asked if there was anything he would change if he could start again, and he replied (paraphrased 'cos I can't find the quote) "Yeah, I'd put the 'n' in 'umount'"
Going forward, perhaps these commands should also be available as functions with the command syntax being supported but deprecated.
It's not really a big issue, but it would tidy things up.