Page 2 of 4 <1234>
Topic Options
#90315 - 2002-12-05 09:15 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
Yeah. I agree. Thats why I said 'bug' in quotes. I does, actually, sort correctly, just as a string which.
Top
#90316 - 2002-12-06 07:00 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Chris

With your permission - may we include this as a demonstration script published on the Kixforms.org website ? Like bbChecker and a couple others, this script demonstrates a varied array of forms features (listviews, buttons, graphics, dialogs, events, ) ... great script ...

-Shawn

Top
#90317 - 2002-12-06 09:14 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
Absolutely. I'd be honored. I'm not completely done with it yet, though. I'd like to add some more features. Clean up the code. Etc.

BTW, you mentioned the other day that you had some ideas. Anything you'd like to share?

Top
#90318 - 2002-12-06 09:37 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
great - will watch this space for your gold edition script.

suggestions: yeah just a couple right now. small stuff really:

1) Suggest you BeginUpdate/EndUpdate on the form rather than on the control, specifically I changed this line:

; $lvwProcessList.EndUpdate
$frmProcesses.BeginUpdate

and

; $lvwProcessList.EndUpdate
$frmProcesses.EndUpdate

Im not completely satisfied yet with the control level Begin/EndUpdates ... for some reason (and I think its a windows problem) when the EndUpdate is executed on a control, the desktop does a refresh as well. You may or may not have noticed this - and it may be OS dependent - but try running your script standalone against the desktop, might see it. Using Begin/EndUpdate with the form itself is much better - only caveat is that the whole form frozen, which is usually ok unless you got a progressbar happening while your loading the listview.

2) Moved the $frmProcess.Show down to just before the loop, and commented out the proggy refreshes (was there a reason for those?), like this:

; $prgCPUUsage.Refresh
; $prgMEMUsage.Refresh
$frmProcess.Show

Find that the form flips a little better with this configuration ... just some thoughts ...

-Shawn

Top
#90319 - 2002-12-06 09:41 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
I put the refreshes in there becuase I found that if I monitored a process with no activity the progress bar was 'grey' until the progressbar value changed.
Top
#90320 - 2002-12-06 09:43 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Was thinking that was the case - is there any way to repro this in a scriptlet ? or using your script ?
Top
#90321 - 2002-12-06 09:48 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
I double checked before I posted to verify I wasn't talking out of my ___. [Wink] For me, it does it everytime I monitor a process in which either one of the CPU or MEM usage values doesn't change.
Top
#90322 - 2002-12-06 09:50 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Even if you move the Show down to after the commented-out Refreshes ?
Top
#90323 - 2002-12-06 09:52 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
Ah. That was the part I missed. Yeah, that works better.

Anyway to complete remove the 'frame' from around the progressbar?

Top
#90324 - 2002-12-06 10:00 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Yeah - give it a shot - might look a little more tskmgr-like.
Top
#90325 - 2002-12-06 10:09 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
You've probaly already noticed that there are issues with changing the borderstyle ? Working on it ...
Top
#90326 - 2002-12-06 10:33 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Try moving BorderStyle as the last setting:

code:
$prgCPUUsage = $picCPUUsage.ProgressBar
$prgCPUUsage.Height = 30
$prgCPUUsage.Width = 30
$prgCPUUsage.Center
$prgCPUUsage.Top = 5
$prgCPUUsage.ForeColor = Lawngreen
$prgCPUUsage.BackColor = Black
$prgCPUUsage.Orientation = 1
$prgCPUUsage.Style = 1
$prgCPUUsage.Max = 100
$prgCPUUsage.BorderStyle = 0

already fixed in next released.

Top
#90327 - 2002-12-06 10:38 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
By the way - think it looks pretty cool with the border or without - so its your call.
Top
#90328 - 2002-12-06 10:40 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
Thanks, Shawn. Actually, now that I see it, I think I like it better with the line border. [Roll Eyes]
Top
#90329 - 2003-04-26 03:07 PM Re: beta - KiXforms: ProcessMon
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22332
Loc: OK
chris...
is there updates to this?
I get from monitoring all the time processor values around 80-95 whereas the taskman next to this shows 20-40...
_________________________
!

download KiXnet

Top
#90330 - 2003-04-27 12:45 AM Re: beta - KiXforms: ProcessMon
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22332
Loc: OK
k, think I was lost there for a while...

it does not work the same way as task manager and that got me confused.
it works just perfectly on that part.
_________________________
!

download KiXnet

Top
#90331 - 2006-01-24 07:02 PM Re: beta - KiXforms: ProcessMon
Chris S. Offline
MM club member
*****

Registered: 2002-03-18
Posts: 2368
Loc: Earth
Edited code to work with the latest build of KF 2 (not dot net yet).

Please forgive the blatant disregard of best practices for the use of the goto statement. What can I say, but I was young and stupid.

Top
#90332 - 2006-01-24 10:47 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Added some snaps (without Chris's permission, hope you no mind) for folks that want to check it out but not install the stuff.
Top
#90333 - 2006-01-24 11:02 PM Re: beta - KiXforms: ProcessMon
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11564
Loc: CA
What's with the 39MB of memory for FireFox there Shawn?

Did you fix the GOTO code for Chris ?

Top
#90334 - 2006-01-24 11:41 PM Re: beta - KiXforms: ProcessMon
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
idk man, I was downloading something from kixhelp.com and firefox started spasming about non-standard html and java code - idk man ;0)

You saying my process list looks odd ? ;0)

Top
Page 2 of 4 <1234>


Moderator:  Shawn, ShaneEP, Arend_, Jochen, Radimus, Glenn Barnas, Allen, Mart 
Hop to:
Shout Box

Who's Online
1 registered (Allen) and 181 anonymous users online.
Newest Members
skygreen2031, amelindarķe, Nims123, davidscroegh, davidscroe
17626 Registered Users

Generated in 0.139 seconds in which 0.077 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org