Page 1 of 1 1
Topic Options
#89803 - 2002-11-27 09:37 AM Kixforms and special characters
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
just noticed that kixforms goes buubuu with and

I know that you americans don't use those but we here in -pean union do.

so, could we get kixforms to understand them?
_________________________
!

download KiXnet

Top
#89804 - 2002-11-27 09:42 AM Re: Kixforms and special characters
Jochen Administrator Offline
KiX Supporter
*****

Registered: 2000-03-17
Posts: 6380
Loc: Stuttgart, Germany
what you mean ?

Works for me , ie. in .caption, .text,

Sample ?

[Big Grin]

[ 27. November 2002, 09:53: Message edited by: jpols ]
_________________________



Top
#89805 - 2002-11-27 10:09 AM Re: Kixforms and special characters
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
send a PM and go see what happens.

anyway, after testing, it seems not to be a problem of kixforms but KiX.

as it does have a hard time with scandinavian chars too.

so, dunno, should ask ruud to have some width in the language support.
_________________________
!

download KiXnet

Top
#89806 - 2002-11-27 10:33 AM Re: Kixforms and special characters
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
ok, my stupidity it was.
just checked the sourcecode and thought it had nothing to do with html...

well it does not, but url does and when posting form data, I need to url-encode that, which comes to %80

{edit}
re-read my message and thought, I could translate it:
-no it's not related to kixforms
-no it's not related to kix

[ 27. November 2002, 10:55: Message edited by: Lonkero ]
_________________________
!

download KiXnet

Top
#89807 - 2002-11-27 04:23 PM Re: Kixforms and special characters
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
just to get more to this.
it's not totally me bad.
wondered why when I read a topic I get ????????? checked and kix writes the response to file as ????? even though, the actual stuff is:
;&+ؠ

just don't know, sending them works fine and board shows them fine, so what is wrong with kix as it does not show them...
_________________________
!

download KiXnet

Top
#89808 - 2002-11-27 07:58 PM Re: Kixforms and special characters
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22344
Loc: OK
ok, cause found.
and I was again blaming wrong tree.
if you change your IE codepage to UTF-8 (unicode) you will see it braking over half of the characters above.
found in xmlhttp was that xmlhttp-object translates the text but with .textbody it returned rawdata which worked just fine.
_________________________
!

download KiXnet

Top
Page 1 of 1 1


Moderator:  Shawn, ShaneEP, Ruud van Velsen, Arend_, Jochen, Radimus, Glenn Barnas, Allen, Mart 
Hop to:
Shout Box

Who's Online
1 registered (Allen) and 289 anonymous users online.
Newest Members
Praveer, Ollero, rayyo, Foxlicht, DonChild
17742 Registered Users

Generated in 0.034 seconds in which 0.012 seconds were spent on a total of 12 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org