Page 1 of 1 1
Topic Options
#6540 - 01/01/29 01:29 PM Drive mapping
kjhoskin Offline
Fresh Scripter

Registered: 01/01/29
Posts: 47
Loc: Plymouth, Devon, UK
I'm running a test w2k and I've got a script mapping some drives which work fine, apart from one drive that doesn't map all the time. All the drives I'm trying to map are on the same box apart from the troublsome one which sits on a Quantum Snap server. This drive is a user scratch area and being on a snap server has the advantage of being easily shared between Mac, Netware, NT and Unix. Trouble is it doesn't always map I'm just doing a basic mapping to it nothing fancy

Use v: \\scratch\scratch1

Has anyone had the same kinda problem???

Kerry

Top
#6541 - 01/01/29 01:55 PM Re: Drive mapping
Shawn Administrator Offline
Administrator
*****

Registered: 99/08/13
Posts: 8608
Kerry:

Might want to place the following after your troublesome map...

Use v: \\scratch\scratch1
?"error: @serror (@error)"

What's the value of @error ?

Shawn.

[This message has been edited by Shawn (edited 29 January 2001).]

Top
#6542 - 01/01/29 02:34 PM Re: Drive mapping
Anonymous
Unregistered


Have you tried use v: "\\scrath1\scratch" ??
Top
#6543 - 01/02/07 04:30 PM Re: Drive mapping
kjhoskin Offline
Fresh Scripter

Registered: 01/01/29
Posts: 47
Loc: Plymouth, Devon, UK
ok I've stuck an error trap in and I'm getting

error: The specified network name is no longer avaliable (64)

I'm sure this is to do with the share being on a Snap server. The rest of the domain is Win2000, the snap server sort of pretends to be an NT4 member server.

I might try and map the share in a couple of places in the script and see what happens

Kerry

Top
#6544 - 01/02/09 05:45 PM Re: Drive mapping
Anonymous
Unregistered


Kerry,

We are using Quantum Snap Servers in our lab to mimic the structure of our production environment. As such, Iíve run into the same problem as you have Ė sometimes the drives just donít map. To fix it, I created a loop. If the drive fails to map, it informs you of this with a message box.

Of course, you can always delete the message box if your users donít like it, and you can increase the number of repetitions if you are still having problems. Iíve found, however, that it usually only takes a few tries to get it mapped, and I never see the message box unless the Snap Server is off-line.

Hereís the code for my loop:
_________________

$count = 0

;Map X Drive
do
$mapped = "0"
$count = $count + 1
If $count = "10"
$Window = MessageBox("X Drive Server not available or drive is already mapped.", "ERROR.", 0)
$count = 0
$mapped = "1"
Else
use X: \\snaplab\xdrive
If @error = 0
$mapped = "1"
EndIf
EndIf
until $mapped = "1"
__________________

Hope that helps,

Ryan

Top
#6545 - 01/02/09 06:53 PM Re: Drive mapping
kjhoskin Offline
Fresh Scripter

Registered: 01/01/29
Posts: 47
Loc: Plymouth, Devon, UK
hiya,

Cheers for the reply I'm glad someone else is having the same problem! I've emailed Quantum tech support so I'll wait and see what the say. In the meantime I've been writing a loop in to my script this afternoon and it works fine.

Cheers

Kerry

Top
#6546 - 01/02/09 07:13 PM Re: Drive mapping
Bryce Offline
KiX Supporter
*****

Registered: 00/02/29
Posts: 3164
Loc: Houston TX
Just a quick test and I was able to make a connection to my snap server during logon with only 1 try.

my snapserver version is
Quantum Snap! Server v2.4.437

This is a new device for us, we just got 1 month ago. it is configured as a Domain member server.

Not sure if any of this helps.....

Bryce


Top
#6547 - 01/02/10 12:50 AM Re: Drive mapping
kjhoskin Offline
Fresh Scripter

Registered: 01/01/29
Posts: 47
Loc: Plymouth, Devon, UK
We have the same version snap Bios on our box. The problem only occurs about 20% of the time, but with only a coupe of hundred users this can actually mean a lot of failed maps. Creating a loop to map the snap server does seem to solve the problem its just a pain!

cheers

Kerry

Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Chris S., Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
1 registered (green78) and 144 anonymous users online.
Newest Members
Keris2112, Jorromans, qrstuv140696, Bloodboy, NIJAKIX
17451 Registered Users

Generated in 0.142 seconds in which 0.106 seconds were spent on a total of 12 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org