Page 1 of 3 123>
Topic Options
#45918 - 2003-09-24 02:32 AM changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Hi guys, I was just wondering if there was an easy way to change the "beep" sound that occurs during logon, I wouldn't mind changing it to the chime.wav sample file that came with KiX. Thanks in advance. I forgot to mention this in my last post, but you guys are great and very helpful. I probably wouldn't have been able to get my script working without you.

Justin

Top
#45919 - 2003-09-24 02:39 AM Re: changing the beep sound
Les Offline
KiX Master
*****

Registered: 2001-06-11
Posts: 12734
Loc: fortfrances.on.ca
Why does it beep during logon for you? It doe not beep for me. There should not be any beep unless there is an error.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#45920 - 2003-09-24 02:45 AM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Hmm I suppose there is an error then. I'm deploying the script using a GPO, and a box doesn't appear. I've heard that if I deploy the script in the profile of the user a box will then appear. I will try this now and report back.
Top
#45921 - 2003-09-24 02:47 AM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
In my user account, I specified a logon script instead of the GPO, however no box appeared and it did beep. All the mappings worked however.
Top
#45922 - 2003-09-24 07:32 AM Re: changing the beep sound
Kdyer Offline
KiX Supporter
*****

Registered: 2001-01-03
Posts: 6241
Loc: Tigard, OR
Can you post your script? Maybe KiXStrip or PostPrep would highlight the issue.

Kent
_________________________
Utilize these resources:
UDFs (Full List)
KiXtart FAQ & How to's

Top
#45923 - 2003-09-24 04:59 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
IF INGROUP("GDPLCA-payroll")
use s: /delete /persistent
use S: "\\vnsv20007\payroll"
if @error <> 0
? "Error: " + @error + " " + @serror
endif
ELSE
? "Ingroup returned false."
ENDIF

IF INGROUP("Domain Users")
use g: /delete /persistent
use g: "\\vnsv20007\server"
if @error <> 0
? "Error: " + @error + " " + @serror
endif
ELSE
? "Ingroup returned false."
ENDIF

IF INGROUP("DPRLCA-accpac")
use p: /delete /persistent
use p: "\\vnsv20007\accpac"
if @error <> 0
? "Error: " + @error + " " + @serror
endif
ELSE
? "Ingroup returned false."
ENDIF

IF INGROUP("DPRLCA-FinanceShare")
use f: /delete /persistent
use f: "\\vnsv20007\finance"
? "Error: " + @error + " " + @serror
endif
ELSE
? "Ingroup returned false."
ENDIF

Top
#45924 - 2003-09-24 05:04 PM Re: changing the beep sound
Kdyer Offline
KiX Supporter
*****

Registered: 2001-01-03
Posts: 6241
Loc: Tigard, OR
Running this through KiXStrip, we see:

code:
 IF INGROUP("DPRLCA-FinanceShare")
USE f: /delete /persistent
USE f: "\\vnsv20007\finance"
? "Error: " + @error + " " + @serror
ENDIF
ELSE
? "Ingroup returned false."
ENDIF
; -------> Warning KIXSTRIP: 38 block "if/else/endif" incompleted. starting point of block structure missing.
; -------> Warning KIXSTRIP: 38 block incompleted.

Resulting message:
quote:

Warning KIXSTRIP: 1 error in block structure. missing statement(s).
- do:until [0:0]
- for|each:in|to:step|next [0|0:0|0:0|0]
- function:endfunction [0:0]
-ERROR- - if:else:endif [7:4:8]
- select:case:endselect [0:0:0]
- while:loop [0:0]
8 block_structures found.
Informative KIXSTRIP: no UDF's found.
Warning KIXSTRIP: some lines contains errors or possible errors.

HTH,

Kent
_________________________
Utilize these resources:
UDFs (Full List)
KiXtart FAQ & How to's

Top
#45925 - 2003-09-24 05:04 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Yea so it would be cool if we could figure out why its beeping and why no window is poppign up. if you guys have any more questions about my network enviroment I'll be around.
Top
#45926 - 2003-09-24 05:06 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Interesting KD, I'll have to review my syntax. might I ask what tool you're using for that?
Top
#45927 - 2003-09-24 05:09 PM Re: changing the beep sound
Sealeopard Offline
KiX Master
*****

Registered: 2001-04-25
Posts: 11162
Loc: Boston, MA, USA
As you've alreayd been told, there's an error in running your KiXtart script. Specifically, as KiXstrip shows you, you do not have matching ENDIFs for all your IFs. Please indent your code in order to find those mismatches.

So, remove all the errors in your KiXtart script, and potentially in the calling batch file, and the beep sound will go away. This has nothing to do with your network infrastructure.
_________________________
There are two types of vessels, submarines and targets.

Top
#45928 - 2003-09-24 05:13 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
will do sealeopard, thanks.
Top
#45929 - 2003-09-24 05:25 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Ok so I've corrected the error in my if loops, is there a simple command to run a sound file?
Top
#45930 - 2003-09-24 05:29 PM Re: changing the beep sound
Richard H. Administrator Offline
Administrator
*****

Registered: 2000-01-24
Posts: 4945
Loc: Leatherhead, Surrey, UK
Yes, check out the Play command in the manual.
Top
#45931 - 2003-09-24 05:32 PM Re: changing the beep sound
Kdyer Offline
KiX Supporter
*****

Registered: 2001-01-03
Posts: 6241
Loc: Tigard, OR
For KiXstrip, have a look at -

KiXtart FAQ & How to's

and, specifically..
How do we check and format code for scripts?

HTH,

Kent
_________________________
Utilize these resources:
UDFs (Full List)
KiXtart FAQ & How to's

Top
#45932 - 2003-09-24 05:35 PM Re: changing the beep sound
Kdyer Offline
KiX Supporter
*****

Registered: 2001-01-03
Posts: 6241
Loc: Tigard, OR
I have to ask..

Are you still having a "Beep" issue? Or, are you looking for how to play a sound?

Kent
_________________________
Utilize these resources:
UDFs (Full List)
KiXtart FAQ & How to's

Top
#45933 - 2003-09-24 05:57 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
the beep issue is over. I thought it was beeping by default, not because I had an error in my code. Now that I've corrected the error its working fine with no beeps. I wouldn't mind having a small sound file play at logon for that extra assurance so I know the script is running.
Top
#45934 - 2003-09-24 05:58 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
I will read up on the play command, thanks.
Top
#45935 - 2003-09-24 06:01 PM Re: changing the beep sound
Kdyer Offline
KiX Supporter
*****

Registered: 2001-01-03
Posts: 6241
Loc: Tigard, OR
quote:

Now that I've corrected the error its working fine with no beeps. I wouldn't mind having a small sound file play at logon for that extra assurance so I know the script is running.

Why? Why not have a screen that shows a logical progression.. There are a couple of Progressbar scripts..

Kent
_________________________
Utilize these resources:
UDFs (Full List)
KiXtart FAQ & How to's

Top
#45936 - 2003-09-24 06:04 PM Re: changing the beep sound
Sealeopard Offline
KiX Master
*****

Registered: 2001-04-25
Posts: 11162
Loc: Boston, MA, USA
Wouldn't the script window be enough? No need to get fancy.
_________________________
There are two types of vessels, submarines and targets.

Top
#45937 - 2003-09-24 06:08 PM Re: changing the beep sound
justinm Offline
Getting the hang of it

Registered: 2003-09-11
Posts: 50
Kent that would be cool but No window shows up...
Top
Page 1 of 3 123>


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 180 anonymous users online.
Newest Members
diefnet, Arogya, gkustra, emnipetro, Hirze
17644 Registered Users

Generated in 0.04 seconds in which 0.01 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org