Page 1 of 1 1
Topic Options
#32297 - 2002-11-13 01:14 AM Issues launching script when using RAS
Annino Offline
Fresh Scripter

Registered: 2002-01-16
Posts: 6
Loc: Sydney

I'm having a bit of an issue while running a minimal login script for dial-up users. The initial batch file runs sweet. It determines if a user is dialed in or not. It runs the script when on the LAN but when I am dialled in, running KiX from the local computer doesn't work. It sits there for a few minutes and bombs out of the batch file. I have an NT 4 domain with KiXtart 4.11 and a windows 98 client. KiX files are on all domain controllers and on the local computer. If KiX files are not on the local computer, KiX runs from the domain controller and copies the required files to the computer within the KiX script. If I run \\BDC\netlogon\logon.bat manually, it worked fine. It's only when I'm dialled in. I hope someone can help me out as this is getting sooo frustrating. Do KiX DLL's have to be in the path of the computer for them to work or is it enough to have them in the same directory as KiX32.exe. Thanks in advance for your help, Annino
Here is the initial batch file to launch the script:

REM *** Begin check for Dial Up connection ****
if exist %windir%\system32\RASAPI32.DLL goto ras_status
if exist %windir%\system\RASAPI32.DLL goto ras_status
goto LAN

if not exist %WINDIR%\kix32\NUL md %WINDIR%\KIX32
if exist %windir%\kix32\checkras.exe goto yes_checkras
copy %0\..\subscripts\system\checkras.exe %windir%\kix32

REM Checking for RAS connection
if errorlevel 1 goto RAS
goto LAN

REM *** Launch Kix from Domain Controller ***
echo Loading Login Script from Domain Controller. Please wait...
%0\..\kix32.exe %0\..\Subscripts\DomainMain.KIX
goto end

REM *** Launch Kix from local computer ***
echo RAS connection detected. Checking for local Kix files...
if not exist %windir%\kix32\kix32.exe goto LAN
echo Loading Login Script from local computer. Please wait...
%WINDIR%\Kix32\kix32.exe %0\..\Subscripts\DomainMain.KIX


#32298 - 2002-11-13 01:23 AM Re: Issues launching script when using RAS
Howard Bullock Offline
KiX Supporter

Registered: 2000-09-15
Posts: 5809
Loc: Harrisburg, PA USA
0) Use KiXtart 4.12

1) Put Kix32.exe, kx??.dll's in the %windir% directory. (Win9x) NT & up only needs Kix32.exe.

2)Have the batch file always copy Kixtart using "XCOPY /D" to keep it current.

3) Always call Kix32 from %windir% and the script from the network (on the LAN or not)

4) use the @RAS in the KiXtart script to determine if you have a RAS session.

[ 13. November 2002, 01:24: Message edited by: Howard Bullock ]
Home page:

#32299 - 2002-11-26 06:37 AM Re: Issues launching script when using RAS
Annino Offline
Fresh Scripter

Registered: 2002-01-16
Posts: 6
Loc: Sydney
I have sorted out the whole determining if I'm dialled up or not. When it gets to the section of the batch file to launch launch KiX locally for a dial up user, I have the command - START /W %WINDIR%\KIX32\WKIX32.EXE %0\..\Subscripts\Main.KIX

Problem is, in the Kixtart.log, I have the message "Fatal Exception Occurred. Error : (0xc0000005/-1073741819)

I've upgraded to version 4.12 on all domain controllers and on the local computer. I've also updated the KXRPC service on all domain controllers.

It works on Win2k dial up. It also works if I'm dialled in with Win9x and manually run the script on the domain controller from the local machine. It only has the issue during login. I understand the issues with the Z: drive being disconnected but I'm using the recommended START /W

Quite frustrating...

Any more help would be very much appreciated.



#32300 - 2002-11-26 07:48 AM Re: Issues launching script when using RAS
Lonkero Administrator Offline
KiX Master Guru

Registered: 2001-06-05
Posts: 22346
Loc: OK
did you try that w9x part with z:\script.kix?

also makes wonder, doesn't the error say "access denied"?

download KiXnet

Page 1 of 1 1

Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 299 anonymous users online.
Newest Members
fobrien, NetGnostic, William_h, ali_cat, Quicky76
17787 Registered Users

Generated in 0.049 seconds in which 0.02 seconds were spent on a total of 12 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google: