Page 1 of 1 1
Topic Options
#214007 - 2021-08-15 12:27 PM @PRODUCTTYPE Bug in Kixtart 4.67
Robdutoit Offline
Hey THIS is FUN
***

Registered: 2012-03-27
Posts: 342
Loc: London, England
On Server 2019, @PRODUCTTYPE reports the server as Windows Server 2016

Also would be useful if when checking Windows 10, it returned more useful information like 1909 or 21H1.

Top
#214018 - 2021-09-24 07:02 AM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: Robdutoit]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11619
Loc: CA
Thanks for the report. Not sure if Ruud will be doing any more updates at this point or not
Top
#214052 - 2022-02-17 03:51 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: NTDOC]
JNK Offline
Fresh Scripter

Registered: 2006-04-11
Posts: 33
Loc: USA
*BUMP*

Windows 11 is detected as Windows 10.

So, is anyone else (besides me) still using Kix for Logon Scripts or are folks moving to Powershell? I am getting pressure to move away from Kix but doing so is a major under-taking that I ... 1) Don't have time to do; and 2) Don't want to do (to be quite honest)

Top
#214053 - 2022-02-17 09:49 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: JNK]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4536
Loc: USA
I sent an email to Ruud. Hoping he will respond or show up here in the forums.
Top
#214054 - 2022-02-18 08:58 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: Allen]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2119
Loc: Tulsa, OK
I don't remember the key off hand, but fairly certain you can get OS info using registry reads as well. This removes the dependency on the built-in macro being updated.
Top
#214055 - 2022-02-18 08:59 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: ShaneEP]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2119
Loc: Tulsa, OK
http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=213202
Top
#214056 - 2022-02-21 04:04 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: ShaneEP]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4536
Loc: USA
Ruud responded to my email and says that as time allows, he plans to update Kixtart.
Top
#214057 - 2022-03-04 09:24 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: Allen]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11619
Loc: CA
Cool to hear he's still doing updates after all these years
Top
#214069 - 2022-04-08 02:39 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: NTDOC]
Ruud van Velsen Moderator Offline
Developer
*****

Registered: 1999-05-06
Posts: 391
Loc: Amsterdam, The Netherlands
Just to be sure you have all seen this.... here's a link to a test-version of 4.69:
KiXtart 4.69

This version recognizes Windows 11, Windows Server 2019, 2022 (and the builds in between) and it also features 2 new macros:
@RELEASEID (eg: 1909, 2003, etc)
@RELEASENAME eg: 21H2)

If nothing unexpected comes up, I'll share a final build shortly.

Top
#214071 - 2022-04-13 04:40 PM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: Ruud van Velsen]
chojin Offline
Just in Town

Registered: 2020-02-26
Posts: 1
Loc: France
Hello,

Thank you Rudd for still providing updates to KiXtart, which I have been using for almost 2 decades.

I really think there is still use for this awesome program, when you don't want to mess with Powershell and GPOs.

By the way, wouldn't putting KiXtart to github be an opportunity to make this project live on?

Top
#214076 - 2022-04-14 12:04 AM Re: @PRODUCTTYPE Bug in Kixtart 4.67 [Re: chojin]
Glenn Barnas Administrator Offline
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4372
Loc: New Jersey
Ruud - we have Kix-based apps running on over 90-K endpoints. The ReleaseId/Name macros will be very useful. I'll see what I can do to test 4.69. Thanks for your continued support!!

FYI - We still experience issues with scripts tokenized on an earlier version reporting strange errors when executed on newer versions. This error is often something like "invalid method/function call: missing comma!" referencing a source line that is blank or in the middle of a series of comments. This does not occur with small or simple scripts, but our source code often exceeds 10,000 lines with up to 150 UDFs referenced. Happy to share an example privately if that will help

Glenn


Edited by Glenn Barnas (2022-04-14 02:07 AM)
Edit Reason: typo
_________________________
Actually I am a Rocket Scientist! \:D

Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart 
Hop to:
Shout Box

Who's Online
2 registered (Ulrich68, mole) and 187 anonymous users online.
Newest Members
SHEBLU_HOSSAIN, JohnShearer, sam_white, Luuraap, mve666
17800 Registered Users

Generated in 0.067 seconds in which 0.029 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org