Page 2 of 3 <123>
Topic Options
#212442 - 2017-04-21 05:24 AM Re: Fatal exception occurred [Re: Shawn]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4455
Loc: USA
Here's a well timed article that just came up after you posted Shawn
https://www.neowin.net/news/microsoft-re...irtual-machines

Top
#212443 - 2017-04-21 11:08 AM Re: Fatal exception occurred [Re: Allen]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
Thanks for stopping by Shawn \:\)
I haven't read anything on Microsoft's side regarding this issue.
Allen: great link!! \:D

Top
#212444 - 2017-04-21 11:38 AM Re: Fatal exception occurred [Re: Allen]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
 Originally Posted By: Allen
I've never installed any version other than kixforms classic. I realized that the message said it wanted .net, but I never used that, so it was just as confusing to me as to why it wanted it.


Sorry for spotting this too late, but essentially the script wanted kixforms.net
You can see it in the code, the difference is in the object.
kixtart.system = KiXforms Classic
kixforms.system = KiXform .Net

Most likely you had a .Net version of Kixomatic (I've translated it a while back)
Your code probably has this:
 Code:
$System = CreateObject("Kixforms.System")
If Not $System
   $nul= MessageBox("KiXforms.Net Not Initiated. This Script Will Now Close.","Error",16)
   Quit()
EndIf

Top
#212445 - 2017-04-21 11:40 AM Re: Fatal exception occurred [Re: Arend_]
BradV Offline
Seasoned Scripter
****

Registered: 2006-08-16
Posts: 679
Loc: Maryland, USA
I have been having a horrible problem on my Windows 10 Home workstation after the creators update. A lot of times, the network connection just fails. At first I thought they had done something to disable firefox, but IE didn't work either. Then I noticed that I could not reach my mail server. That is internal at my house. It isn't always the case, just now and then. Very frustrating. \:\(
Top
#212446 - 2017-04-21 11:43 AM Re: Fatal exception occurred [Re: BradV]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
 Originally Posted By: BradV
I have been having a horrible problem on my Windows 10 Home workstation after the creators update. A lot of times, the network connection just fails. At first I thought they had done something to disable firefox, but IE didn't work either. Then I noticed that I could not reach my mail server. That is internal at my house. It isn't always the case, just now and then. Very frustrating. \:\(


I doubt this has to do with the Creators Update, I have been having similar problems with Windows 10 from the start. Folders that are open in Explorer that point to folders on mapped drives disconnect all the time as well. And sites I'm logged in to using Chrome such as my monitoring system require me to login a couple of times a day.
I think W10 disconnects idle sessions or something.

Top
#212447 - 2017-04-21 03:39 PM Re: Fatal exception occurred [Re: Arend_]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4455
Loc: USA
Arend you are correct. I had select kixomatic2 instead of kixomatic... and the versions do translate to classic vs .net.

With that said, I tried installing what I think is the latest .net version of kixforms and it's saying it needs .net 1.1, Is that correct?

Top
#212448 - 2017-04-21 03:52 PM Re: Fatal exception occurred [Re: Allen]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2080
Loc: Tulsa, OK
I know there's probably no way this changes anything. But has anyone tried running DoEvents(1) with the async option? I have a vague memory of that fixing someones issue in the past. Even though this is probably a much bigger problem. Just currious if it get different results...

 Code:
$System = CreateObject("KiXtart.System")
$Form = $System.Form()
$Form.Show()
While $Form.Visible
   $Nul = Execute($Form.DoEvents(1))
Loop
Exit 0

Top
#212449 - 2017-04-21 03:56 PM Re: Fatal exception occurred [Re: Allen]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
 Originally Posted By: Allen
Arend you are correct. I had select kixomatic2 instead of kixomatic... and the versions do translate to classic vs .net.

With that said, I tried installing what I think is the latest .net version of kixforms and it's saying it needs .net 1.1, Is that correct?


I think the latest version of KiXforms .net runs on .Net Framework 2.0

Top
#212450 - 2017-04-21 03:56 PM Re: Fatal exception occurred [Re: ShaneEP]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
 Originally Posted By: ShaneEP
I know there's probably no way this changes anything. But has anyone tried running DoEvents(1) with the async option? I have a vague memory of that fixing someones issue in the past. Even though this is probably a much bigger problem. Just currious if it get different results...

 Code:
$System = CreateObject("KiXtart.System")
$Form = $System.Form()
$Form.Show()
While $Form.Visible
   $Nul = Execute($Form.DoEvents(1))
Loop
Exit 0


Yeah tried that, but still no dice.
It did get by some hangs, but would crash eventually anyway.

Top
#212451 - 2017-04-21 04:58 PM Re: Fatal exception occurred [Re: Arend_]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4455
Loc: USA
On Windows 10 1703, if I use the kixforms301.msi this is the error I get...

 Quote:
This setup requires the .NET Framework versaion 1.1.4322. Please install the .NET Framework and run this setup again. The .NET Framework can be obtained from the web. Would you like to do this now?


Clicking the link takes you to a ms website but not 1.1 .NET. My understanding is, .NET 1.1 wont install on Win 10 anyway. So in my Programs and Features I see that I have the .Net 3.5 (includes 2.0) installed.

I extracted the dll and tlb files from the msi and copied the files to system32. Then I ran the following command:

 Code:
C:\Windows\Microsoft.NET\Framework64\v2.0.50727\regasm kixforms.system.dll


Said "Types Registered Successfully"

However, when I run kixomatic.net i still get "Kixforms.net Not Initiated. This Script Will now Close."



Any suggestions?


Top
#212452 - 2017-04-21 05:27 PM Re: Fatal exception occurred [Re: Allen]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4455
Loc: USA
Got it working. Copied the kixforms files to syswow64 and ran the 32bit version of regasm.
Top
#212453 - 2017-04-21 05:28 PM Re: Fatal exception occurred [Re: Allen]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
Last KiXform .Net version that I have is 3.2.16.
Afaik that runs on .net 2.0.

Top
#212454 - 2017-04-21 05:42 PM Re: Fatal exception occurred [Re: Arend_]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4455
Loc: USA
Download link for 3.2?
Top
#212455 - 2017-04-21 07:32 PM Re: Fatal exception occurred [Re: Allen]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
From 3.2.5 .Net 1.1 was dropped in favor of .Net 2.0.
Last version can be found here

Top
#212461 - 2017-04-24 04:10 PM Re: Fatal exception occurred [Re: Arend_]
Arend_ Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
Small update: If you boot into Safe Mode, KiXforms 2.47.5 works without issue.
So it seems to be some kind of DEP (Data Execution Prevention) that got added in the Creators Update.
I've completely disabled Windows Defender, Smart Screen etc. but the problem still exists in "Normal Mode".
I've even freshly installed a laptop with the Creators Update ISO to make sure it wasn't the 'Upgrade' process that caused the problem.

Now the good news: Shawn is working on a version that has a workaround for the problem and it seems to work.

Top
#212467 - 2017-04-29 06:13 AM Re: Fatal exception occurred [Re: Shawn]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11571
Loc: CA
Who is this imposter?

Welcome Shawn - if but for a brief moment in time. Hope all is going well for you

Cheers

Ron

Top
#212468 - 2017-05-02 03:45 AM Re: Fatal exception occurred [Re: NTDOC]
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Hi Ron, really glad to hear from you, all is going well.

Kix on, my brother !

-Shawn

Top
#212471 - 2017-05-02 07:10 PM Re: Fatal exception occurred [Re: Shawn]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11571
Loc: CA
You're coming up on your 18 year anniversary on the forum here in about 3 months. You've been around on this forum longer than many have been in IT Shawn.
Top
#212473 - 2017-05-02 11:57 PM Re: Fatal exception occurred [Re: NTDOC]
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
LOL!, ahhhhhhyeaaaa, thanks for reminding me of that buddy ;\)
Top
#212526 - 2017-05-18 04:03 PM Re: Fatal exception occurred [Re: Shawn]
PrebenJ Offline
Just in Town

Registered: 2005-03-27
Posts: 4
Loc: Denmark
Would be really nice if Kixforms Classic could run on the latest Windows 10 Creators Update - I can confirm the problem as well as it stopped working on the new computers we deploy when entering the DoEvents loop.

/Preben

Top
Page 2 of 3 <123>


Moderator:  ShaneEP, Mart, Radimus, Jochen, Allen, Glenn Barnas 
Hop to:
Shout Box

Who's Online
1 registered (Bryce) and 183 anonymous users online.
Newest Members
gkustra, emnipetro, Hirze, thequeen, ameliaryan
17642 Registered Users

Generated in 0.05 seconds in which 0.016 seconds were spent on a total of 14 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org