Page 1 of 1 1
Topic Options
#211906 - 2016-08-24 04:02 PM Windows 10 error ??
DKBofh Offline
Fresh Scripter

Registered: 2016-06-29
Posts: 9
Loc: Denmark
I have a kix script running in a win 7 enviroment + a few win 10 machines :-)

On the win 10 machines one thing will not work when login on but works fine when runned manually

RUN "c:\login\test.bat" - this is a test file - normally it is used for login in to a SSO client (starting it - linked through AD)

I made a test calling a lnk to a pdf document to rule out the application.
The PDF is called from the batch file.

I do not have that much hair left but this removes the last.

Tried with v4.53 + 4.66 - and nothing happens in windows 10 at logon,

Any experience regarding issues like this i hope some of you can and will share ??
_________________________
/Erik
----------------------------------
I'm always up for extra vacation.

Top
#211907 - 2016-08-24 05:26 PM Re: Windows 10 error ?? [Re: DKBofh]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4414
Loc: USA
What's the contents of the bat?
Have you put in any debug info in the bat to make sure its actually running it?

Top
#211908 - 2016-08-24 10:04 PM Re: Windows 10 error ?? [Re: Allen]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11563
Loc: CA
Check your Event Logs and make sure nothing is up there.

This applies to Windows 8.1 so I would guess it also applies to Windows 10, though I've not looked up the link for Windows 10


Logon scripts do not run for five minutes after a user logs on to a Windows 8.1-based computer
https://support.microsoft.com/en-us/kb/2895815

The Startup Script is Dead
https://blogs.technet.microsoft.com/askpfeplat/2015/04/26/the-startup-script-is-dead/

Top
#211909 - 2016-08-25 01:31 AM Re: Windows 10 error ?? [Re: NTDOC]
Lonkero Administrator Offline
KiX Master Guru
*****

Registered: 2001-06-05
Posts: 22303
Loc: OK
This is a windows 10 computer. Nothing, absolutely nothing works right on those.

That being said, technically since NT4.0 in order to run .bat files, you need to specify the interpreter.
So you run command.com or cmd.exe with your script as an argument.

Your way was never SUPPOSED to work in the first place.
_________________________
!

download KiXnet

Top
#211910 - 2016-08-25 09:40 AM Re: Windows 10 error ?? [Re: Allen]
Arend_ Moderator Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1862
Loc: Hilversum, The Netherlands
 Originally Posted By: Allen
What's the contents of the bat?
Have you put in any debug info in the bat to make sure its actually running it?

I don't think Bruce would like that...

Top
#211911 - 2016-08-25 10:35 AM Re: Windows 10 error ?? [Re: Arend_]
DKBofh Offline
Fresh Scripter

Registered: 2016-06-29
Posts: 9
Loc: Denmark
Hi .....

Will investigate further....


Edited by DKBofh (2016-08-25 11:24 AM)
_________________________
/Erik
----------------------------------
I'm always up for extra vacation.

Top
#211912 - 2016-08-25 01:47 PM Re: Windows 10 error ?? [Re: DKBofh]
DKBofh Offline
Fresh Scripter

Registered: 2016-06-29
Posts: 9
Loc: Denmark
Hmmmmmm......

Shell ; SHELL "c:\login\sso12.bat" will not work :-( nor when i'm using sleep with it (see below)

But..... this do - after the sleep was inserted (started with 5 and it works but just to make sure i put on 2 ekstra secs.

IF $OS =W7
run "c:\login\sso12.bat"
GOSUB REGFIX
else
run "c:\login\sso12.bat"
sleep 7
ENDIF

GOSUB VELKOMST1 (the last thing to do - welcome the user before ending the script)

Why the H.... the sleep is needed makes me wonder but it works so I think i will leave it there and keep on testing to make sure i can login at least a 100 times on different machines before going "into production"
_________________________
/Erik
----------------------------------
I'm always up for extra vacation.

Top
#211913 - 2016-08-25 02:05 PM Re: Windows 10 error ?? [Re: DKBofh]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4641
Loc: The Netherlands
Just a wild guess but I think you need the sleep because Run does not wait until the command it executed is done. It continues with the next command directly after the Run command. Shell does wait until the thing executed by Shell is finished before it continues to the next line in the script.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#211914 - 2016-08-25 02:32 PM Re: Windows 10 error ?? [Re: Mart]
DKBofh Offline
Fresh Scripter

Registered: 2016-06-29
Posts: 9
Loc: Denmark
THX..... at least an explanation. :-)

/Erik
_________________________
/Erik
----------------------------------
I'm always up for extra vacation.

Top
#211935 - 2016-09-02 01:08 PM Re: Windows 10 error ?? [Re: DKBofh]
Jochen Administrator Offline
KiX Supporter
*****

Registered: 2000-03-17
Posts: 6361
Loc: Stuttgart, Germany
Hej my fellow BofH.

You may try it with Allens way to be found here: http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=209906&fpart=1

Have successfully replaced a GPO based, Network dependant, Printer mapping construct which ran for at least 15 seconds with an XML/ADODB based kix script which was timed with 0.010 to 0.030s if the printers were at least mapped once ;\)
Well, as it seems there is now a follow me print solution in place, but that's progress which is cool for BofHs
_________________________



Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 22 anonymous users online.
Newest Members
Hadfevfegrt477a, Hdrthtsr19956, Kylie99, msmile042, rayd8
17598 Registered Users

Generated in 0.078 seconds in which 0.033 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org