Page 1 of 1 1
Topic Options
#207551 - 2013-07-30 01:14 PM @ADDRESS Returns Blank String
BillBarnard Offline
Starting to like KiXtart

Registered: 2007-03-14
Posts: 141
Loc: Leighton Buzzard, Bedfordshire...
I am finding that @ADDRESS macro is occasionally returning a blank string on some Windows 7 systems. Anyone found this?
Can @ADDRESS be extended to display more than one MAC address, similar to the @IPADDRESSx macros, to cater for multiple network adaptors?
I am still using Kixtart 4.53 on our logon scripts as we still have some legacy systems.
i.e. WinNT4 and Win 2k. Which, I think, Kixtart 4.6x will not run on.
Cheers,
Bill
_________________________
Bill

Top
#207715 - 2013-09-10 01:00 PM Re: @ADDRESS Returns Blank String [Re: BillBarnard]
BillBarnard Offline
Starting to like KiXtart

Registered: 2007-03-14
Posts: 141
Loc: Leighton Buzzard, Bedfordshire...
I can confirm now that @address returns a blank string on many Windows 7 laptops, when the Ethernet network adaptor is used. If the wireless adaptor is used then @address returns the MAC address of the wireless adaptor successfully.

Can @address be made to find the MAC address of the active network adaptor please?
_________________________
Bill

Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Ruud van Velsen, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 49 anonymous users online.
Newest Members
srm11671, Brack, SpaceJunk, canandan, cfvrr
17695 Registered Users

Generated in 0.031 seconds in which 0.012 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org