Page 1 of 2 12>
Topic Options
#202874 - 2011-08-16 10:59 AM Kixtart 4.62 and Kixforms classic not playing nice on Windows 7
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4642
Loc: The Netherlands
I think I found a serious bug (at least in my case it is a huge show stopper) while testing my logon script with 4.62.

I start a dummy kf classic form to see if kf is installed and select what script to run depending on the outcome (kf version or non kf version).
All is fine on WinXP but on Win7 and Win7SP1 it throws a fatal exception right away. It looks like 4.62 is not playing nice with kf classic on Win7 and Win7SP1. I tested this on two Win7 32bits systems one with SP1 and one without SP1 and it fails on both. 4.61 works fine on XP, 7 and 7 with SP1 installed.
Can someone please check this to confirm that Iím not going crazy?

 Code:
Break on

$rc = CreateObject("Kixtart.Form")


Edited by Mart (2011-08-16 02:27 PM)
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#202881 - 2011-08-16 05:42 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Mart]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2081
Loc: Tulsa, OK
I am also seeing issues. I just created a simple test form with the code below, and although I dont see any errors, the form never shows, it just quits immediately. If I copy 4.61 back into place, the same code works fine.

 Code:
$System = CreateObject("KiXtart.System")
$Form = $System.Form()
$Form.Show()
While $Form.Visible
   $Nul = Execute($Form.DoEvents)
Loop
Exit 0


I am using Windows 7 SP1 64-bit.

Also, I added "? @SError" lines after each line and they all say success, but the form never shows.


Edited by ShaneEP (2011-08-16 05:57 PM)

Top
#202884 - 2011-08-16 07:47 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: ShaneEP]
Glenn Barnas Administrator Offline
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4291
Loc: New Jersey
I'm not having the problem - Windows 7 SP1 X64

This shows that I'm running 4.62 (kix32 /?), shows the sample code, and the execution of that code. Also, I've been using tsAdm and another GUI tool since upgrading to 4.62 without any issue.

I'm using KixForms 2.47.5.0

Glenn
_________________________
Actually I am a Rocket Scientist! \:D

Top
#202885 - 2011-08-16 09:29 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Glenn Barnas]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2081
Loc: Tulsa, OK
Strange. I would say that I just did something wrong when I tested, but the fact that it immediately worked again after placing 4.61 back makes it a bit more suspicious. I will test again when I get home from work tonight.
Top
#202886 - 2011-08-16 09:35 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: ShaneEP]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2081
Loc: Tulsa, OK
Just out of curiousity, have you tried using wkix32.exe? Also...where did you get kixforms.dll ver 2.47? I can only find 2.46.
Top
#202887 - 2011-08-16 09:38 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: ShaneEP]
Ruud van Velsen Offline
Developer
*****

Registered: 1999-05-06
Posts: 359
Loc: Amsterdam, The Netherlands
Excellent find, thanks for the report.
Curiously, this does not appear to be the result of a code change in KiX itself, but due to some change in the VS2010 compile/build run. (Because if I build the 4.61 code, the same issue appears...) Maybe a change in the runtime libraries, maybe the optimization.

Also strange is the fact that everything else appears to work just fine, including automation of other COM objects..

This will require some investigation, and as I'll be busy elsewhere the next weeks, I'm afraid it may take a while to fix.

Ruud

Top
#202888 - 2011-08-16 09:41 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Ruud van Velsen]
Ruud van Velsen Offline
Developer
*****

Registered: 1999-05-06
Posts: 359
Loc: Amsterdam, The Netherlands
Ah, only just now saw Glenn's post: I've been testing with KF 2.46.

So if 2.47 indeed works fine, there indeed appears some curious compat issue between KX 2.46 and KiXtart built with VS 2010.

Hmmm.

Anyway, thanks for the testing, excellent work!

Ruud

Top
#202889 - 2011-08-16 09:52 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: ShaneEP]
Jochen Administrator Offline
KiX Supporter
*****

Registered: 2000-03-17
Posts: 6373
Loc: Stuttgart, Germany
Shane, Ruud,

the latest and greatest is always to be found in here:

Kixforms Classic Development build
_________________________



Top
#202890 - 2011-08-16 09:55 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Mart]
Jochen Administrator Offline
KiX Supporter
*****

Registered: 2000-03-17
Posts: 6373
Loc: Stuttgart, Germany
btw, Mart,

Kixtart.Form is a bit deprecated IIRC .. it's been a long time, but I think using Kixtart.System Object is the preferred way of initialising kf.Classic
_________________________



Top
#202892 - 2011-08-17 01:34 AM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Jochen]
ShaneEP Moderator Offline
MM club member
*****

Registered: 2002-11-29
Posts: 2081
Loc: Tulsa, OK
I can confirm that replacing kixforms 2.46.55 with 2.47.4 resolved the problem for me.
Top
#202897 - 2011-08-17 05:09 AM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: ShaneEP]
It_took_my_meds Offline
Hey THIS is FUN
*****

Registered: 2003-05-07
Posts: 273
Loc: Sydney, Australia
Speaking of KiXforms, has anyone heard from Shawn?
Top
#202898 - 2011-08-17 05:49 AM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Ruud van Velsen]
Glenn Barnas Administrator Offline
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4291
Loc: New Jersey
Hmm.. the links on the KF site show 2.47.4, and I have 2.47.5.

This was a KF.DLL that Shawn sent me about 2 years ago when I was developing some Sockets-based code, so I don't know if it's been "released". It's worked well for all my apps, and I have some heavy socket-based code running between the US and Aus, as well as some local helpdesk type stuff that's GUI intensive and uses Sockets as well.

Glenn
_________________________
Actually I am a Rocket Scientist! \:D

Top
#202899 - 2011-08-17 09:15 AM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Jochen]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4642
Loc: The Netherlands
 Originally Posted By: Jochen
btw, Mart,

Kixtart.Form is a bit deprecated IIRC .. it's been a long time, but I think using Kixtart.System Object is the preferred way of initialising kf.Classic



Ok. Didn't know that. That's what you get for copying and pasting parts from other (older) scripts .
Changing Kixtart.Form to Kixtart.System gives the same results on kf 2.46. Upgrading to kf 2.47 works fine. I'll update my scripts and install 2.47. Thanks for the help.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#202900 - 2011-08-17 09:23 AM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: It_took_my_meds]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4642
Loc: The Netherlands
 Originally Posted By: It_took_my_meds
Speaking of KiXforms, has anyone heard from Shawn?


Every now and then he does a drive by but it has been a while since Iíve seen him online. His last post is from July 20th 2011. I guess he is not doing so much kix work nowadays.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#202902 - 2011-08-17 03:30 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Mart]
It_took_my_meds Offline
Hey THIS is FUN
*****

Registered: 2003-05-07
Posts: 273
Loc: Sydney, Australia
I know it's a bid morbid... but what if Shawn dies.

Does anyone have the source code? I for one have a SIGNIFICANT investment in KiXforms (and of course KiXtart) code. I've been able to work around a number of limitations using DynaWrap etc but whilst KiXforms 2.47.4 is excellent, it has a number of expected limitations and is going to eventually need to be upgraded without eventually causing serious problems for those of us who have very large business critical scripts that rely heavily on it.

This will be especially apparent when Windows 8 opens up to a lot to native coders what was once the realm of .NET and vice versa. Sadly, I've heard no statement of intent, he just seemed to (at least to me) have disappeared. I've got sooo much to thank him for, I would like to hear his words on KiXforms just as I'm always excited to hear from Ruud.

Top
#202903 - 2011-08-17 03:35 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: It_took_my_meds]
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
I visit the board every other day or so. Don't post much anymore though. I'm always willing to look at and revisit any compatibility issues, at least until old age sets-in ;-)

[edit]

Ok, maybe less than every other day or so.

Top
#202904 - 2011-08-17 03:42 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Shawn]
Allen Administrator Offline
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Shawn, Glenn brought up having a .5 release instead of .4. I just downloaded .4 off the kforms site. Is there a newer release that just didn't make it to your site?
Top
#202905 - 2011-08-17 03:55 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Allen]
Shawn Administrator Offline
Administrator
*****

Registered: 1999-08-13
Posts: 8611
Glenn and I were working on some special customizations for a project he had. When I get a chance, will check the latest build number and advise. Will refresh it on kforg if possible.
Top
#202906 - 2011-08-17 05:01 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: Shawn]
Glenn Barnas Administrator Offline
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4291
Loc: New Jersey
FYI - I've been using this version everywhere without any known issue. YMMV, of course. \:\)

Glenn
_________________________
Actually I am a Rocket Scientist! \:D

Top
#202909 - 2011-08-17 07:21 PM Re: Kixtart 4.62 and Kixforms classic not playing nice on Windows 7 [Re: It_took_my_meds]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11571
Loc: CA
 Originally Posted By: It_took_my_meds
I know it's a bid morbid... but what if Shawn dies.

Does anyone have the source code?


There is an archive of his source code but without his permission even if he did pass away we would not be able to release it.

Top
Page 1 of 2 12>


Moderator:  ShaneEP, Arend_, Jochen, Radimus, Glenn Barnas, Allen, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 186 anonymous users online.
Newest Members
diefnet, Arogya, gkustra, emnipetro, Hirze
17644 Registered Users

Generated in 0.154 seconds in which 0.124 seconds were spent on a total of 14 queries. Zlib compression enabled.