Page 1 of 1 1
Topic Options
#197869 - 10/02/24 05:52 PM KIX and Windows 7 logon script issue
IMan Offline
Fresh Scripter

Registered: 09/04/23
Posts: 15
Loc: California
When i logon to a windows 7 PC the script shows up for a second then dissapears and nothing is mapped, but if i manually run it then it works fine, i turned off UAC thinking that was the issue but it is still happening. Any suggestions? I am running Windows 7 Enterprise with Kix version 4.61. I also have windows xp pro PC's using the same script with no issues.
Top
#197872 - 10/02/24 07:47 PM Re: KIX and Windows 7 logon script issue [Re: IMan]
Glenn Barnas Moderator Offline
KiX Supporter
*****

Registered: 03/01/28
Posts: 3822
Loc: New Jersey
Is this a traditional or GPO script?

If traditional, what is the user profile setting where the script is defined?

If it launches with a BAT file, can you post it?

Glenn
_________________________
Visit the Inno-Tech web site for Kix tools/UDFs
Lost:Rocket, appx 8' tall, Green w/ yellow fins, nose, and computer bay.. Last seen streaking skyward in NY

Top
#197964 - 10/03/03 11:34 AM Re: KIX and Windows 7 logon script issue [Re: Glenn Barnas]
RUgolini Offline
Just in Town

Registered: 10/03/03
Posts: 2
Loc: Italy
Hello everybody, I'm new at this forum.
I have the same problem of IMan.
I have a traditional KIX script laucnhed by a .CMD file.. With Windows 7, the script didn't start..
My CMD file is on the Domain Server here: %LOGONSERVER%\NETLOGON\

Where should be the problem with Windows 7 (in my company we have a lot of Windows XP clients, and the script works fine..)

Thank you all,
Roberto

Top
#197966 - 10/03/03 12:01 PM Re: KIX and Windows 7 logon script issue [Re: RUgolini]
Mart Moderator Online   content
KiX Supporter
*****

Registered: 02/03/27
Posts: 4423
Loc: Rotterdam, The Netherlands
Hi Roberto,

In the future please start a new thread and if needed link to any other threads that are relevant for your issue.

The script does not run at all or is it just not visible?
Windows 7 (as did Windows Vista) show the welcome screen until the scrip(s) are done and the desktop is fully loaded. You can disable that by setting the registry keys below.

Have a look at this KB article: http://support.microsoft.com/kb/940452

 Quote:

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
Value: DelayedDesktopSwitchTimeout
Data: 0
_________________________
Mart

- I don't have an attitude! I just have a personality that you cannot handle! - Jerry the mouse.

Top
#197967 - 10/03/03 12:16 PM Re: KIX and Windows 7 logon script issue [Re: Mart]
RUgolini Offline
Just in Town

Registered: 10/03/03
Posts: 2
Loc: Italy
Hi Mart,
sorry for my mistake !!

Well I use the script to map network drive and network printer, and the script didn't start at all..

Thank you again
Roberto

Top
#197980 - 10/03/05 03:47 PM Re: KIX and Windows 7 logon script issue [Re: RUgolini]
Mart Moderator Online   content
KiX Supporter
*****

Registered: 02/03/27
Posts: 4423
Loc: Rotterdam, The Netherlands
Sorry for the late reply.

Can you start the script manually after logon?
_________________________
Mart

- I don't have an attitude! I just have a personality that you cannot handle! - Jerry the mouse.

Top
#198077 - 10/03/16 02:15 PM Re: KIX and Windows 7 logon script issue [Re: Mart]
miklein Offline
Just in Town

Registered: 10/03/16
Posts: 2
Loc: Deutschland
Hello,

i have the same problem with windows 7. Seee post: http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=198076#Post198076

when the primarygroup variable ist empty the script not conneted my network
shares. This doesnt happen at every login. At the next login the variable ist not empty and then the script connect my shares.

Sample Script:
If @PRIMARYGROUP = "group"
use n: "\\server\share0"
use p: "\\server\share1"



Greetings

Michael

Top
#198079 - 10/03/16 05:01 PM Re: KIX and Windows 7 logon script issue [Re: miklein]
Mart Moderator Online   content
KiX Supporter
*****

Registered: 02/03/27
Posts: 4423
Loc: Rotterdam, The Netherlands
Please do not cross post.
See the reply in http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=198076
_________________________
Mart

- I don't have an attitude! I just have a personality that you cannot handle! - Jerry the mouse.

Top
Page 1 of 1 1


Moderator:  Bryce, Jochen, Howard Bullock, Allen, Sealeopard, Radimus, Kdyer, Chris S., Glenn Barnas, Benny69, ShaneEP, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 40 anonymous users online.
Newest Members
CPELISSON, The_Bas, quantum_jav, alonebfg, softmicro
16738 Registered Users

Generated in 0.04 seconds in which 0.014 seconds were spent on a total of 14 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org