Page 2 of 2 <12
Topic Options
#196609 - 2009-11-09 02:56 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Ruud van Velsen]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Here is a really old (2002) thread that might still have some value. http://www.adminscripteditor.com/forum/printable.asp?m=687
and
the MS KB DOC
http://support.microsoft.com/kb/262958

Top
#196627 - 2009-11-10 12:03 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
Tunster Offline
Just in Town

Registered: 2006-09-04
Posts: 2
We're experiencing this issue as well with our network. However, we have a mixed W2003 and W2K server AD environment.

Both of other W2K servers are pretty much defunct now. Hopefully sometime tonight or tomorrow, we're going to demote them both to test this W2K theory out. Ideally, we want to introduce our Windows 2008 servers into the AD domain, but can't do so until we raise the forest level.


Edited by Tunster (2009-11-10 01:43 PM)

Top
#196669 - 2009-11-12 03:53 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Tunster]
Ruud van Velsen Offline
Developer
*****

Registered: 1999-05-06
Posts: 359
Loc: Amsterdam, The Netherlands
Just a short update: I can now confirm this is an issue in Windows 7. It is apparently caused by the new (stricter) SMB signing settings of Windows 7.

It may be possible to work around the issue by tweaking the SMB settings, but this is clearly not for the faint-of-heart and should be carefully considered and aligned with the security guidelines you have in place.

I will update this post if and when a fix for Windows 7 is made available.

Ruud

Top
#196670 - 2009-11-12 04:11 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Ruud van Velsen]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Thanks for the update Ruud.
Top
#196683 - 2009-11-13 09:32 AM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
Ruud van Velsen Offline
Developer
*****

Registered: 1999-05-06
Posts: 359
Loc: Amsterdam, The Netherlands
And one more update: a fix for the issue is available and a Knowledgebase article on it should be published in the coming weeks. The fix will be included in an upcoming service pack for Windows 7. Until then, you can get the fix by contacting Microsoft Support and referring to 976494.

Note that there is no workaround or fix I can create in KiXtart.

Kind regards,

Ruud

Top
#196684 - 2009-11-13 10:28 AM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Ruud van Velsen]
Richard H. Administrator Offline
Administrator
*****

Registered: 2000-01-24
Posts: 4945
Loc: Leatherhead, Surrey, UK
Good result, thanks for following up.
Top
#196690 - 2009-11-13 03:37 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Richard H.]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
So I guess there will be two versions of the patch (32, and 64bit)... anyone have support with MS and willing to contribute...

Arend?

Top
#196693 - 2009-11-13 09:20 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11571
Loc: CA
That type of fix should be Free from Microsoft Allen.
Top
#196724 - 2009-11-17 12:01 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: NTDOC]
Arend_ Moderator Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
Sounds like it, I'm gonna run the test on a 32-bit machine in a minute.
I've had similar problems using WDS.

Actually pretty much the same error.
When deploying Windows 7 from a 2003 WDS server (still W2K domain)
The logon account fails.

When deploying Windows 7 from a 2008 WDS server (still W2K domain)
The logon account succeeds.

Deploy Vista or 2008 (R1) from either servers and you don't get the problem.

The error code you get in WDS is simply 0x80070056.
Which relates to exactly the same problem as KiXtart, authentication fails/invalid credentials/password/username.


Unfortunately I am sort of a Maverick in my Company, loose cannon, I'm not even yet supposed to test Windows 7, let alone ask headquarters to makea ticket for it...

Top
#196730 - 2009-11-17 03:35 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Arend_]
Arend_ Moderator Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
Update: x86 Machine has the same problems.
So yeah most likely 2 different patches.

Top
#196925 - 2009-12-01 11:24 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Arend_]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Well... looks like the patch count is up to 4 now. Add 2008 Server 32 and 64bit to the list.
http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=196923#Post196923

I wonder if this information has been passed on to MS?

Top
#196992 - 2009-12-04 08:03 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Hot off the presses...

Error 1789 when you use the LookupAccountName function on a computer that is running Windows 7 or Windows Server 2008 R2
http://support.microsoft.com/kb/976494/en-us

And you can request the hotfix online (no phone call)
http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=976494&kbln=en-us

Top
#197106 - 2009-12-14 03:19 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
Arend_ Moderator Offline
MM club member
*****

Registered: 2005-01-17
Posts: 1865
Loc: Hilversum, The Netherlands
I can Confirm the fix really does fix the problem. Thanks Allen :-)
Top
#197839 - 2010-02-21 06:46 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Arend_]
Galeocerdo Offline
Fresh Scripter

Registered: 2002-05-02
Posts: 9
Thanks, this is going to save me a lot of grief.
Top
#198295 - 2010-03-31 03:40 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
synwave7 Offline
Fresh Scripter

Registered: 2002-01-27
Posts: 49
Loc: Chicago, IL. 60601
Sorry I cannot lend a hand but I am trying to give back in small measure as everyone on this site is so great in thier help to me. I do agree this sounds like something to do with the AD (schema) and it's interaction with Kix. When we updated our AD to 2008 here where I work, we did have to bring microsoft in to build a special hotfix for some various issues that arose out of updating our AD to 2008. Hope this helps some.

Syn
_________________________
Bang that head that doesn't bang!!!

Top
#199371 - 2010-08-06 03:12 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
Dynamite Dan Offline
Fresh Scripter

Registered: 2003-04-29
Posts: 20
Loc: BelgiŽ
This should fix the ingroup function not working on Win7 of Win2k8R2 machine
http://support.microsoft.com/kb/976494

current setup AD2000 domain and win7 client, kix 4.60
after applying the hotfix the kix script and ingroup function worked

Top
#200596 - 2010-11-12 05:36 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Dynamite Dan]
Biggus Offline
Fresh Scripter

Registered: 2010-11-12
Posts: 5
Loc: England
The microsoft hotfix sorted this out for my Windows 7 and AD2000 domain
Top
#201736 - 2011-03-11 10:18 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Biggus]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4459
Loc: USA
Just curious if anyone with this problem has tried SP1 yet, to see if the fix is in fact included.
Top
#203501 - 2011-11-07 03:18 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: Allen]
bruheard Offline
Just in Town

Registered: 2011-11-04
Posts: 1
Loc: AL, USA
I applied SP1 and it seemed to work. The drives are mapped and some other policies applied, but I don't see ScriptLogic running as I log on.
Top
#203502 - 2011-11-07 04:06 PM Re: Kix 4.61+ INGROUP + Windows 7 [Re: bruheard]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4642
Loc: The Netherlands
All you see is the welcome screen right? This is by design.
If you Google on delayeddesktopswitchtimeout you will get soem hits with a "fix" for this.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
Page 2 of 2 <12


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 180 anonymous users online.
Newest Members
diefnet, Arogya, gkustra, emnipetro, Hirze
17644 Registered Users

Generated in 0.042 seconds in which 0.012 seconds were spent on a total of 14 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org