Page 1 of 1 1
Topic Options
#187403 - 2008-04-30 08:53 PM Ingroup fails with a RDP session ?
fgagnonks Offline
Just in Town

Registered: 2008-04-30
Posts: 4
I have searched the forum and could not found a related issue, so here it is:

Loging in remotly as "Administrator" to a server using Citrix, this script works and maps the Z: correctly.

IF InGroup("GroupName")
USE Z: /Delete /Persistent
USE Z: "\\DC01\ShareName"
ENDIF

But the same login to the same server using a RDP session (Terminal Server), the script starts but does not recognise the "Administrator" as being a member of "GroupName" and fails to map de Z: drive.
If I use "Debug ON" I can see it the IF InGroup("GroupName") and then the script ends.

This is with Kixtart 4.60 2010

Why ?

What is missing ?

How to fix this ?

Thanks.



Edited by fgagnonks (2008-04-30 09:09 PM)

Top
#187408 - 2008-04-30 10:49 PM Re: Ingroup fails with a RDP session ? [Re: fgagnonks]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11564
Loc: CA
Please try version 4.53 and see if that one works as expected.

If it does then let us know - it may be an unknown bug with the 4.60 version.

Top
#187410 - 2008-04-30 11:05 PM Re: Ingroup fails with a RDP session ? [Re: NTDOC]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4641
Loc: The Netherlands
Not a bug in 4.60 imho.
Work just fine for me on local logons and terminal (RDC) sessions from WinXP pro to Win2K server and Win2K3 server and from Vista enterprise to Win2K and Win2K3 server. Both on the local LAN and with an SSL VPN tunnel over the internet.

Not sure and cant check right now but I recall something about a Terminal server tab in the users properties. Some settings can be set there especially for TS logons.


Edited by Mart (2008-04-30 11:08 PM)
Edit Reason: Added some stuff.
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#187412 - 2008-05-01 12:37 AM Re: Ingroup fails with a RDP session ? [Re: Mart]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11564
Loc: CA
I'm not sure either and I don't have a problem running 4.53 over Cisco VPN with RDC - have not tried the 4.60 version.

Maybe his code, or maybe something else he's running that we don't run that is causing an issue. Only takes a minute to try a different version of KiXtart though to see if that's the cause. If it too has an issue then probably need to post the entire logon script to see if someone can spot an issue.

Top
#187414 - 2008-05-01 01:32 AM Re: Ingroup fails with a RDP session ? [Re: NTDOC]
Glenn Barnas Administrator Offline
KiX Supporter
*****

Registered: 2003-01-28
Posts: 4282
Loc: New Jersey
RDC? Is that something new - RDP over RPC? Or are you guys secretly train buffs and subliminally referencing Rail Diesel Cars?



Glenn
_________________________
Actually I am a Rocket Scientist! \:D

Top
#187415 - 2008-05-01 01:47 AM Re: Ingroup fails with a RDP session ? [Re: Glenn Barnas]
Les Offline
KiX Master
*****

Registered: 2001-06-11
Posts: 12734
Loc: fortfrances.on.ca
RDC uses RDP. Everyone knows that.

RDC = Remote Desktop Client
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#187439 - 2008-05-02 05:49 PM Re: Ingroup fails with a RDP session ? [Re: Les]
fgagnonks Offline
Just in Town

Registered: 2008-04-30
Posts: 4
Problem has been identified but not fixed yet

1 - I installed KiXtart 2010 4.53 and it behaves the same way
2 - If user A logs onto B's copmputer, the Z: is mapped
3 - If user B logs onto A's computer the Z: is mapped
4 - if A or B log onto their computer the Z: is NOT mapped.

It looks like there is something in the profile that prevents the "Ingroup" to properly identify if the user really is in the group.

Why does InGroup do that ?

Thanks

Top
#187440 - 2008-05-02 06:10 PM Re: Ingroup fails with a RDP session ? [Re: fgagnonks]
BillBarnard Offline
Starting to like KiXtart

Registered: 2007-03-14
Posts: 141
Loc: Leighton Buzzard, Bedfordshire...
I think, the first use command, use z: /del /pers
will fail as it's incorrect syntax, you can't use both /del and /pers in the same use command, it's one or the other.
Assuming the KiXtart USE is similar syntax to the NET USE command line one.
Perhaps this affects the second use comand.
Remove /pers from the first use command.

D:\>net use z: /del /pers
You used an option with an invalid value.

The syntax of this command is:

NET USE
[devicename | *] [\\computername\sharename[\volume] [password | *]]
[/USER:[domainname\]username]
[/USER:[dotted domain name\]username]
[/USER:[username@dotted domain name]
[/SMARTCARD]
[/SAVECRED]
[[/DELETE] | [/PERSISTENT:{YES | NO}]]

NET USE {devicename | *} [password | *] /HOME

NET USE [/PERSISTENT:{YES | NO}]

More help is available by typing NET HELPMSG 3505.


Regards,

Bill
_________________________
Bill

Top
#187441 - 2008-05-02 06:34 PM Re: Ingroup fails with a RDP session ? [Re: BillBarnard]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4441
Loc: USA
Bill, I think you have the commandline net use, and kixtart use mixed up. using del and persistent with the kix use is proper, and in cases where the mapped drive is created with persistant, you have to use it to remove it.
Top
#187443 - 2008-05-02 06:54 PM Re: Ingroup fails with a RDP session ? [Re: fgagnonks]
Allen Administrator Online   shocked
KiX Supporter
*****

Registered: 2003-04-19
Posts: 4441
Loc: USA
Is the server part of the domain?
Domain or local groups?

Have you tried:
"domainname\groupname"
"servername\groupname"

Don't think this applies here, but Z: is a no no with Win9x.

Top
#187444 - 2008-05-02 07:21 PM Re: Ingroup fails with a RDP session ? [Re: Allen]
fgagnonks Offline
Just in Town

Registered: 2008-04-30
Posts: 4

Is the server part of the domain? YES
Domain or local groups? Domain Groups (Global-Security)

I have tried both and it behaves the same way, it does not work.
"domainname\groupname"
"servername\groupname"

?

Top
#187449 - 2008-05-02 09:51 PM Re: Ingroup fails with a RDP session ? [Re: fgagnonks]
NTDOC Administrator Offline
Administrator
*****

Registered: 2000-07-28
Posts: 11564
Loc: CA
Please post the full script (or at least the entire section where you do this mapping) so that we can see what you're actually coding. Hopefully we can offer further advice based on what's shown.
Top
#187454 - 2008-05-03 01:45 AM Re: Ingroup fails with a RDP session ? [Re: NTDOC]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4641
Loc: The Netherlands
How about flushing the token cache with the /f parameter or by deleting the regkey below?

 Quote:

HKEY_CURRENT_USER\Software\KiXtart\TokenCache
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
#187637 - 2008-05-14 04:19 PM Re: Ingroup fails with a RDP session ? [Re: Mart]
fgagnonks Offline
Just in Town

Registered: 2008-04-30
Posts: 4
Thanks Mart, like you said we tried the /f parameter and it worked.

Problem solved ! \:\)

Thanks !

Top
#187643 - 2008-05-14 08:31 PM Re: Ingroup fails with a RDP session ? [Re: fgagnonks]
Mart Moderator Offline
KiX Supporter
*****

Registered: 2002-03-27
Posts: 4641
Loc: The Netherlands
It's always the simple things that are missed
_________________________
Mart

- Chuck Norris once sold ebay to ebay on ebay.

Top
Page 1 of 1 1


Moderator:  Jochen, Allen, Radimus, Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
1 registered (Allen) and 181 anonymous users online.
Newest Members
skygreen2031, amelindarķe, Nims123, davidscroegh, davidscroe
17626 Registered Users

Generated in 0.045 seconds in which 0.013 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org