Page 2 of 3 <123>
Topic Options
#117942 - 04/04/15 02:46 PM Re: execution time
Shawn Administrator Offline
Administrator
*****

Registered: 99/08/13
Posts: 8606
My goodness, my times look like this:

first run:

In domain users
elapsed=3785

second run:

In domain users
elapsed=271

the user i used is a member of 77 groups ... having said that, still not sure what your next step is ...

Are there any events log entries on your local machine, or on any of your servers pertaining to any of this ?

Top
#117943 - 04/04/15 02:50 PM Re: execution time
Shawn Administrator Offline
Administrator
*****

Registered: 99/08/13
Posts: 8606
btw - the userid your testing with, how many groups does it belong to ? how many entries in the tokencache ?
Top
#117944 - 04/04/15 02:56 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
Quote:

What protocols are on the network?
Currently TCP/IP, Netbios, IPX (IPX will be going later this year)
What network clients on the clients?
MS Windows, Netware (Netware will be going later this year)
Do you have KXRPC service running?
No, I dont know about the finer point of what this would add to the mix yet.




Here is your problem!
You have to optimize your network bindings and provider order!

BTW, you don't need KXRPC unless you are supporting Win9x/ME.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117945 - 04/04/15 03:00 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
YEESH, yes. Thanks for pointing me to the event log. I have about 5 errors occuring.
They are as follows
The description for Event ID ( 53 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: UserGetInfo failed Error : The network path was not found. (0x35/53).

The description for Event ID ( 53 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: UserModalsGet failed Error : The network path was not found. (0x35/53).

The description for Event ID ( 1332 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: GetPG: LookupAccountSid failed Error : No mapping between account names and security IDs was done. (0x534/1332).

The description for Event ID ( 1332 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: GetPrimaryGroup failed Error : No mapping between account names and security IDs was done. (0x534/1332).

The description for Event ID ( 1722 ) in Source ( KIXTART ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: UserGetLocalGroups failed Error : The RPC server is unavailable. (0x6ba/1722).

I am still processing what all this means at the moment though.

Top
#117946 - 04/04/15 03:09 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
the user is a member of 16 groups
Top
#117947 - 04/04/15 03:53 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
So... did you try optimizing the network settings?
I ran a mixed shop of Windows and NetWare for years and speak from experience. Just got rid of NetWare this year.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117948 - 04/04/15 04:13 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
We are going down that road now as well. No I really did not optimize the network settings, but this had been done previously because of what appeared to be network latency issues. However, I did test this script on a win2k station I have. It ran in about 5 seconds there.

I wish I knew what I would have to do to fix this machine though. I changed domains and tried to preserve the registry. This may be where my problem is coming in. Since everything appears to be a SID based problem on this. I have not been deep enough in the registry to bring only 'username/sid' settings from a preserved registry for my new user into this registry.
Other than that I am going to have to consider my registry 'hosed'. At that point my next step is to reinstantiate the HKLM Hive that was created for my new user and take months to try to recreate reg keys.

This topic is becoming beyond the scope of this forum. I don't want to be too OT. But if anyone has any ideas, I would appreciate finishing this by email.

Top
#117949 - 04/04/15 04:16 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
You are really barking up the wrong tree. It has nothing to do with SIDs and the registry and everything to do with the network settings. But hey! if you want to keep banging your head on that tree...
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117950 - 04/04/15 04:23 PM Re: execution time
Shawn Administrator Offline
Administrator
*****

Registered: 99/08/13
Posts: 8606
Quote:


I changed domains and tried to preserve the registry.





Not too sure I understand what your trying to accomplish by "preserving the registry", sounds very unusual and "non-supported" whatever it is.

Top
#117951 - 04/04/15 04:24 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
If I am wrong about the network settings thing I am more than willing to admit it. I don't profess to be the smartest in that arena.

Does the event log entries still make you think that there is a problem with the network settings?

Top
#117952 - 04/04/15 04:42 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
Basicly the reg is a file. I copied this file to the new user.
Top
#117953 - 04/04/15 04:45 PM Re: execution time
Shawn Administrator Offline
Administrator
*****

Registered: 99/08/13
Posts: 8606
I found this link on the net:

Running kixtart with NT Domain logins

Its Ruud discussing issues around the UserModalsGet error (different error code though) and he states that

Quote:


Because of the way KiXtart retrieves information, if the UserModals information can't be retrieved, the user groups are also not retrieved.





Not sure if anything in that link sheds light on any of this.

Top
#117954 - 04/04/15 04:56 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
Yes, the event logs indicate a problem with providers and protocols. Make sure that you do not bind the MS client to anything other than TCPIP and move MS to the top in provider order.

The network APIs that KiX calls are processing requests according to the bindings and provider order. If you were to run a network trace (sniffer), you would see all the failures that populate the event log.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117955 - 04/04/15 06:34 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
When you are talking about the MS client are you talking about the ms client for Netware? We are running the actual Netware client (v4.60.604 SP1).
Top
#117956 - 04/04/15 07:00 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
No, M$ client for M$ networking.

In XP, on the bindings tab, it is:
File and Printer Sharing for Microsoft Networks
- Internet Protocol (TCP/IP)

Client for Microsoft Networks
- Internet Protocol (TCP/IP)


On the Provider Order tab, it is:
Network Providers
- Microsoft Windows Network
- Novell bla bla (going form memory)
- Other providers
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117957 - 04/04/15 08:01 PM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
I dont have the MSClient installed All the bindable services I am showing (on the bindings tab)(all services view) is as follows:
Service->Bound To
3com Smartagent->(NIC)
NetBIOS->NWLink Netbios->IPX/SPX
NetBIOS->Wins->(NIC)
Novell Client->IPX/SPX
Novell Client->TCP/IP->(NIC)
Server->IPX/SPX
Server->NWLink Netbios->IPX/SPX
Server->WINS->(NIC)
Workstation->NWLink Netbios->IPX/SPX
Workstation->WINS->NIC

Top
#117958 - 04/04/15 10:35 PM Re: execution time
Sealeopard Offline
KiX Master
*****

Registered: 01/04/25
Posts: 11161
Loc: Boston, MA, USA
You'll need the MS Client.
_________________________
There are two types of vessels, submarines and targets.

Top
#117959 - 04/04/15 10:45 PM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
Like I said, my view was on XP. YMMV

Your view looks like NT4. I no longer support NT4. NT4 is nearing EOL.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
#117960 - 04/04/16 12:30 AM Re: execution time
burnsc Offline
Starting to like KiXtart

Registered: 04/04/14
Posts: 171
What would be the verbage used for the MS client on NT. Would it be 'Simple TCP/IP services'?
Top
#117961 - 04/04/16 12:58 AM Re: execution time
Les Offline
KiX Master
*****

Registered: 01/06/11
Posts: 12734
Loc: fortfrances.on.ca
There was a time I could recite every option on Win95 and NT4 but interestingly, when I stop supporting them, it just gets purged from my memory.
Now as I am running around the continent migrating divisions to AD, I wish I would have retained some of it.

Since I no longer have NetWare and no NT4 wkstas, I cannot refresh my memory.

Sorry

Why not just bounce around in there on a test machine and see what you can tweak.
_________________________
Give a man a fish and he will be back for more. Slap him with a fish and he will go away forever.

Top
Page 2 of 3 <123>


Moderator:  Jochen, Allen, Radimus, Chris S., Glenn Barnas, ShaneEP, Arend_, Mart 
Hop to:
Shout Box

Who's Online
0 registered and 113 anonymous users online.
Newest Members
schnuggel, h315060, johnnyutah, pmk31, ArserHsieh
17412 Registered Users

Generated in 0.044 seconds in which 0.015 seconds were spent on a total of 13 queries. Zlib compression enabled.

Search the board with:
superb Board Search
or try with google:
Google
Web kixtart.org