(Just in Town)
2013-09-09 09:40 AM
Problem with mapping drives at startup


I just started using KiX, but it seems quite a lot more functional than Batch and I want to use it.

I've now created a script which loops through a txt-file in which I've defined which path should be mapped for a specific letter if the user is in a specific group, like:


Then I split the line using "split()" to get the $group, $letter and $path into seperate variables. The map should be mapped when the user is member of the specified group (Checked via "InGroup( $group )").

Now we get to the problem:

When I try to connect the network-drives using

USE $letter $path /persistent

it works the most of the time. But not always! I've created a log file to get the error code, but it's returning 0 as if the drive was mapped, but it is not mapped on the client computer.

Currently it happened on two client computers running Windows 8 Pro x64, but it's working on other clients with W8 Pro x64 and W7 Pro x64.

Is there anything I've just not seen or I'm doing wrong?

(KiX Supporter)
2013-09-09 10:05 AM
Re: Problem with mapping drives at startup

Hi Janik,

Welcome to the board.

A few questions:
How do you start the logon script? Is it done with a GPO or with the settings in the user profile in AD?
What happens if you start the script manually after logon with a user or workstation that did not get the drives mapped correctly?
Best practice in my book is to run the script synchronized. See: http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=112428#Post112428

(Just in Town)
2013-09-09 10:44 AM
Re: Problem with mapping drives at startup

Hello Mart!

We start kix with a GPO. It's set to start "\\company.local\netlogon\WKIX32.EXE" with the parameter "\\company.local\netlogon\LoginScript.kix".

The Script is called everytime on startup!

If I start the script manually after logon on a client which has not mapped the drives they do get mapped. Same entries in the log-file: @ERROR returns 0.

The GPO-Setting "Always wait for the network at computer startup and logon" is already enabled for every client.

I've even tried using "SLEEP" in the script to wait for up to 10 seconds, but the same issue occured.